数论分块
整数分块
求
性质1:分块的块数
当时,有种取法
当时,,最多也是取法
性质2:l所在块的右端点为
[CQOI2007] 余数求和
题目描述
https://www.luogu.com.cn/problem/P2261
给出正整数 和 ,请计算
其中 表示 除以 的余数。
输入格式
输入只有一行两个整数,分别表示 和 。
输出格式
输出一行一个整数表示答案。
样例输入 #1
10 5
样例输出 #1
29
样例 1 解释
。
数据规模与约定
- 对于 的数据,保证 。
- 对于 的数据,保证 。
- 对于 的数据,保证 。
代码
#include <bits/stdc++.h>
using namespace std;
#define int long long
signed main() {
#ifndef ONLINE_JUDGE
freopen("../test.in", "r", stdin);
freopen("../test.out", "w", stdout);
#endif
int n, k;
cin >> n >> k;
int res = n * k;
int r;
for (int l = 1; l <= n; l = r + 1) {
if (k / l == 0) break;
r = min(k / (k / l), n);
res -= (k / l) * (r - l + 1) * (l + r) / 2;
}
cout << res;
return 0;
}
Strange Function
https://www.luogu.com.cn/problem/CF1542C
题面翻译
记 为最小的正整数数 满足 不是 的因子。
现给出正整数 ,请计算出 模 的值。上述式子等价于 。
本题含多组数据。令数据组数为 ,那么有 ,
题目描述
Let denote the minimum positive integer such that is not a divisor of .
Compute modulo . In other words, compute modulo .
输入格式
The first line contains a single integer ( ), the number of test cases. Then cases follow.
The only line of each test case contains a single integer ( ).
输出格式
For each test case, output a single integer , where modulo .
样例输入 #1
6
1
2
3
4
10
10000000000000000
样例输出 #1
2
5
7
10
26
366580019
提示
In the fourth test case , so .
- is a divisor of but isn't, so is the minimum positive integer that isn't a divisor of . Thus, .
- and are divisors of but isn't, so is the minimum positive integer that isn't a divisor of . Thus, .
- is a divisor of but isn't, so is the minimum positive integer that isn't a divisor of . Thus, .
- and are divisors of but isn't, so is the minimum positive integer that isn't a divisor of . Thus, .
Therefore, .
思路
因为,即是最小的不可以被整除的数,那么一定都是可以被整除的
因此,并且
因为,这里的